This project is read-only.

How do I publish this?

Mar 16, 2009 at 9:17 PM
I feel stupid.

 * I've downloaded the full featured starter kit 
 * extracted to a folder
 * started the solutionfile 
 * modified the web.config to point to a sql 2005 server database I've created
 * ran the solution without debug (ctrl+f5)
 * completed the wizard and set it up with an "empty" site (same root and startpage)

I noticed the solution did not include default.aspx, nor /edit or other needed folders. I tried to publish it thinking that maybe it would automagically work regardless, but of course it didn't.

My guess is that the full features starter kit doesn't work as expected, or I am doing this the wrong way... :-(
Mar 16, 2009 at 9:26 PM
These files are not included in the sample project but they are deployed in the web folder.

You might need to set the database flavour in web.config:

<n2><database flavour="SqlServer2005"/>

It might also help to choose one of the existing export files.
Mar 16, 2009 at 11:00 PM
Ok. Maybe We're getting somewhere now. I replaced sqllite with sqlserver2005, and ran the solution. It runs localhost on cassini now, and I've gotten as far as step 3 where I want to create the tables. I suspect I need to redo the creation since I didn't specify the correct dialect in the beginning. However now I ran into some other issue at step 3. Under the content there is an error:
Line 1: Incorrect syntax near 'MAX'. ved NHibernate.Tool.hbm2ddl.SchemaExport.Execute(Boolean script, Boolean export, Boolean justDrop, Boolean format) ved NHibernate.Tool.hbm2ddl.SchemaExport.Create(Boolean script, Boolean export) ved N2.Installation.InstallationManager.Install() ved N2.Edit.Install._Default.ExecuteWithErrorHandling[T](Execute action)
Mar 17, 2009 at 12:18 AM
Best guess some mismatch between connection string and flavour. If you've checked this with no luck you can download the database script from here and run manually.
Mar 17, 2009 at 2:40 PM
Tried to run the create queries and it failed with this error:

Msg 170, Level 15, State 1, Line 29
Line 29: Incorrect syntax near 'MAX'.

Seems to me that the queres aren't working... :-/
Mar 17, 2009 at 6:19 PM
Are you absolutely certain you are using SQL Server 2005? Can you post your connection string? I'm thinking that the database doesn't support varchar(MAX) which is a new data type in that version of SQL Server.
Mar 18, 2009 at 8:35 AM
I was sure my host ran version 9 (2005), but it seems I've been fooled. But I'll just give it a try running version 8 (sql2000) instead.
Don't hold your breath...
Mar 18, 2009 at 9:05 AM
You wrote "These files are not included in the sample project but they are deployed in the web folder."
I assume this means that rightclicking the project and choosing publish (in VS2008) is not the same as deploy. So how do I deploy?
Currently this error is displayed when I publish the project to the website using FTP (builtin VS2008):

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP404. The resource you are looking for (or one of its dependencies)could have been removed, had its name changed, or is temporarilyunavailable.  Please review the following URL and make sure that it isspelled correctly.

Requested URL: /Templates/UI/Views/Start.aspx


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433              

Mar 18, 2009 at 11:21 AM
I found out how to deploy and I set up first an MVC example. I had to drag a lot of dll's into the bin directory for it to work (the MVC dlls and the Castle dlls). After clicking around in the system av while I found that the MVC example is missing a lot of the nips and dips features that exists in the WebForms example.

Now I am trying to find the right C# startup project as a baseline for a new site. 
There are two candidates:
1) output\Examples\TemplateSite
   This one is missing web.config and reference to N2.Templates (WHY?)
2) output\Templates
   This one seems to contain everything, but doesn't have a project/solution file.

This is starting to get frustrating...
Mar 18, 2009 at 6:24 PM
I tried building with the batch file and the example and the templates files are copied to the example along with web.config. Not sure what's going on on your end.

Couldn't you just use the package from the release tab (Full Featured Starter Kit)?
Mar 18, 2009 at 9:06 PM
Ok. I will try to start all over again. This shouldn't be that hard.
What would be a good way to seperate the downloaded project and the code deployed to a site? 
I want to download, configure, deploy to an online site. After that I want an easy way to update the online site with changes made to n2cms.

:-)
Mar 18, 2009 at 10:21 PM
I added a wiki article on deployment. I would appreciate any updates from real world experience.
Mar 18, 2009 at 10:29 PM
Awesome! :D