Error After playing with addons and removed every addons afterwards

Feb 23, 2009 at 6:55 AM

this is the error i receive when i run my project (no mvc)

Its was working perfectly before adding addons from references


Server Error in '/' Application.

Method 'GetService' on type 'Castle.Windsor.WindsorContainer' from assembly 'Castle.Windsor, Version=1.0.3.0, Culture=neutral, PublicKeyToken=407dd0808d44fbdc' tried to implicitly implement an interface method with weaker type parameter constraints.


Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.TypeLoadException: Method 'GetService' on type 'Castle.Windsor.WindsorContainer' from assembly 'Castle.Windsor, Version=1.0.3.0, Culture=neutral, PublicKeyToken=407dd0808d44fbdc' tried to implicitly implement an interface method with weaker type parameter constraints.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[TypeLoadException: Method 'GetService' on type 'Castle.Windsor.WindsorContainer' from assembly 'Castle.Windsor, Version=1.0.3.0, Culture=neutral, PublicKeyToken=407dd0808d44fbdc' tried to implicitly implement an interface method with weaker type parameter constraints.]
   N2.Engine.ContentEngine..ctor(Configuration config) +0
   N2.Context.CreateEngineInstance() +133
   N2.Context.Initialize(Boolean forceRecreate) +55
   N2.Web.InitializerModule.Init(HttpApplication context) +38
   System.Web.HttpApplication.InitModulesCommon() +65
   System.Web.HttpApplication.InitModules() +43
   System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +729
   System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +298
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +107
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +289

Feb 23, 2009 at 7:07 AM
I decided to remove every reference, recopy the .dll from the wwwroot/bin folder of the n2 sources

and now it's working again.

But still want to know what broke the code.