MVC project loading error in visual studio 2008

Feb 22, 2009 at 9:58 PM
hi there anybody have this problem when loading the mvc demo project in visual studio 2008

visualstudio2008MVCN2error
Coordinator
Feb 22, 2009 at 10:07 PM
Have you installed the sdk (link)?
Feb 23, 2009 at 3:30 AM
just did sorry was stupid of me hehe.
Feb 23, 2009 at 5:50 AM
Edited Feb 23, 2009 at 5:51 AM
Sorry libardo, at the first run of asp.net mvc demo project i get this error.
Do you know what could cause it??Seem that my httpcontext is null or the handler

HttpContext-ErrorOnDebugRun
Feb 28, 2009 at 2:31 PM
I'm getting the same message.

Even if you set the
System.Web.Abstractions
System.Web.Mvc
System.Routing

to point to the the dlls in the Bin directory (i.e. the ones supplied with in the zip).

What would be great is if someone could get a working copy of the demo where all the references except the BCL ones are supplied and referenced in the project.
Feb 28, 2009 at 11:57 PM
Microsoft Visual Studio 2008
Version 9.0.30729.1 SP
Microsoft .NET Framework
Version 3.5 SP1

Installed Edition: Professional

>>> Working for me.



Mar 1, 2009 at 7:53 AM
@mikekidder

Hi Mike

That isn't the issue - it's more the version of the references in the projects.  I'm begining to suspect that it's the ASP.NET RC refresh that's the issue.

Did you install the RC or just the beta?
Mar 1, 2009 at 6:39 PM
Edited Mar 1, 2009 at 6:42 PM
@IainHolder - sorry that was not a really helpful answer on my part...

UPDATE #1:  Duplicated the problem with the "ASP.NET MVC Example" (Dec. 7 release) here on Codeplex.  I am not seeing this issue on the MVC example available on the trunk over at googlecode at http://code.google.com/p/n2cms/source/checkout.    The source code (over a year old) here on CodePlex was a big source of confusion for me. 

An added benefit of the latest code, its updated so the views have no code-behind.   The site.master file still has a code-behind, but I it was easy enough to take care of that.  The rest of this message below may be relevant for others.

@libardo - any way to remove the source here on CodePlex

>>>>>>>>>>>>>>

I have ASP.NET MVC RC installed and did initially have problems with several projects.   Most of my issues stemmed from VS crashing when attempting to view an ASPX page, or launching the Web Development Server (F5, Ctrl+F5). 

However,  I found some helpful information on a question over at StackOverflow:

Post: http://stackoverflow.com/questions/500696/why-does-visual-studio-crash-opening-aspx-with-mvc-rc1

What seemed to work for me was the mention of running ngen.  I also deleted everything under the "Temporary ASP.Net Files" folder in "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727".

Now whether I get the N2CMS code from trunk over at googlecode or the latest build example for the "MVC example" here on codeplex, it all works for me now.

Hope this information helps...
Mar 2, 2009 at 8:02 AM
@mikekidder - Thanks for the reply - I did what you advised:

1. Get latest source from http://code.google.com/p/n2cms/source
2. Deleted all my tmp asp.net files
3. Ran the Prepare_Dependencies-vs2008.bat script.

But I'm still getting an error on start:

Exception Details: System.TypeLoadException: Method 'Create' in type 'Castle.Windsor.Proxy.DefaultProxyFactory' from assembly 'Castle.Windsor, Version=1.0.3.0, Culture=neutral, PublicKeyToken=407dd0808d44fbdc' does not have an implementation.

Source Error:

Line 28: 		{
Line 29: 			// normally the engine is initialized by the initializer module but it can also be initialized this programmatically
Line 30: 			IEngine engine = N2.Context.Initialize(false);
Line 31: 
Line 32: 			RegisterRoutes(RouteTable.Routes, engine);

Source File: C:\dev\n2cms.googlecode.com\examples\Mvc\wwwroot\Global.asax.cs    Line: 30


So I tried referencing the Castle dlls that are included in the source. But I still get the same error.  Is this because I have another version of castle running on my machine?  If so can I do something else to make this compile with all the correct references?