Url Rewriter???

Mar 11, 2008 at 7:50 PM
Hello all,

in the most recent release I don't think the url rewriter is working i have spent most of today and last night trying to see why not. any item i add does not have a working link in the menu system and i get this error:

Server Error in '/GIC website' Application.
The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /GIC website/gic-news-.aspx

Version Information: Microsoft .NET Framework Version:2.0.50727.1434; ASP.NET Version:2.0.50727.1434

also the menu system still does not show the start page as it should.

thanks for any help
Coordinator
Mar 12, 2008 at 8:30 AM
Hi

I don't know a solution to your problem yet (when I try to reproduce your setup it still seem to work). Here are a few ideas that might or might not help you:
  • Is the engine started (this is done either through an httpmodule in web.config or by inheriting a baseclass in your global asax)
  • Does it make any difference if you remove the blankspace from your application name (e.g. move gic website -> gic_website)
  • is the start page template located in {wwwroot}/gic templates/default.aspx?
  • does it work differently if you replace the files in your sites with one of the examples?

And a few questions:
  • what happens if you go for a page through it's rewritten url, e.g. /gic website/default.aspx?page={startpageid}
  • what code are you using (templates, an example, custom + n2)?
Mar 13, 2008 at 6:04 PM
Hello,

Thank you for trying to help. but i had commented out the Httpmodule in the web.config.

i am using 1.3.3 templates and the menus that you have in the example do not show the start page is their a reason. one of the release notes says that they should.

also i am working on a end user login system that i should be done with in about the next week if you would like the code. so that other may use it i will be able to shear that with you.



Coordinator
Mar 13, 2008 at 7:06 PM
Good you solved it. The menus needs to be added as parts (open the white thingie in the upper left corner and drag out a horizontal menu.

I'm thinking of moving the menus to the master page in the next version. I don't see the need to tweak this dynamically anymore.

The login system sounds very interesting. Please share.