This project is read-only.

N2 in 1and1 host

Topics: Developer Forum
Feb 18, 2009 at 6:09 PM
Hello everyone,
i downloaded Example_CS from N2 and tried it in my local computer, and everything works fine.
Then i want to upload it to my host in 1and1, so i uploaded everything, only changing web.config, where i put this line <customErrors mode="Off"/> so i can see the errors.

Well, it doesn't work, you can see the error in http://astaleda.es/portal that is the address where i put it; and you can see the actual web.config at http://astaleda.es/web.txt

I downloaded the source from sqlite from http://sqlite.phxsoftware.com/ so i can modify it and compile a new dll if i need to change something.

So, here's the question, what can i do to put n2 to work on my host?

Thank you so much for your help.
Sorry my english, i hope you can understad what i means. 
Feb 18, 2009 at 6:48 PM
Edited Feb 18, 2009 at 6:48 PM
You need to use another database, e.g. sql server or mysql. There are a few hints in the wiki.
Feb 18, 2009 at 6:56 PM
Hi, thanks for your fast answer.
I cant use sql server or mysql on the host i have (is the lower host), so i only use access and i think i can use sqlite because its only a dll and the file.
there isn't a way to recompile the sqlite dll and allow me to use it in the host??

Thank you again
Feb 18, 2009 at 7:01 PM
I think it's unlikely since the C# driver is just a wrapper around a native implementation. A possible option is trying to change the trust level: <trust level="Full" />. Another is using the Jet driver and an access database.
Feb 18, 2009 at 7:16 PM
Hi again, i change the web.config and put:

  <location allowOverride="true">
    <system.web>
    <trust level="Full"/>

(you can see it at the link i put before)
but it seems not to work, and its strange, because it says that

This configuration section cannot be used at this path.  This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file

but i put the line before that says =true :S
is it correct how i put it?

Thank you again.