404

Topics: Developer Forum, Project Management Forum, User Forum
Feb 9, 2009 at 11:39 AM
Edited Feb 9, 2009 at 11:39 AM
Hi I'm getting a 404 for any page that I try to view that is rewritten when I try to view on live (Windows server 2003)

The config works fine on dev (XP)

Both are using 3.5 sp1.

Are there any differences in the web.config?

Or potential permssions issues to do with re-writing?


    <n2>
        <!-- If you install a database from scrach you'll need to insert some required pages. This can be done by the web based installer located at http://yoursite/install/edit -->
        <host rootID="1" startPageID="2">
            <web extension=""/>
        </host>
        <engine>
            <components>
            </components>
        </engine>
        <!-- Other flavours: SqlServer2005, SqlServer2000, MySql, SqLite -->
        <database connectionStringName="MyConnectionString" flavour="SqlServer2005"/>
        <edit>
            <installer checkInstallationStatus="false"/>
        </edit>
    </n2>

<system.web>
<httpModules>
            <add name="n2.initializer" type="N2.Web.InitializerModule, N2"/>

<httpHandlers>
            <add path="*.n2.ashx" verb="*" type="N2.Web.AjaxRequestHandler, N2"/>

Feb 9, 2009 at 4:32 PM
Fixed it.

Windows server 2003 doesn't map all requests to asp.net, so using the web extension "" resulted in 404.

changed to ".aspx" and works.

Need to have a look at configuring IIS 6 to handle all requests like IIS 7
Coordinator
Feb 9, 2009 at 6:13 PM
The feature is called wildcard mapping. Try using the term in your search.