This project is read-only.

Multiple sites problem

Topics: Developer Forum
Jan 8, 2009 at 9:56 AM
Hello!

I have just moved from x64 hosting to x86 hosting and took the opportunity to install the latest version as well (1.4.4).

I reused the old database from the previous version (which was from about April 2008, dont know version number).

I have about 30 sites in the same N2, all with different host names (domain and subdomains). I have a startpage for each site and have set the host name and different themes for them.

The problem I have now is that the different sites shows content from the first accessed startpage (since iisreset). However, the correct theme is loaded.

If I load a site and get the incorrect content and then add ?asdasd (to make it unique) on the URL, I get the correct content. I have set outputcache="false", but duration remains to the default value (10).

I also have multiplesites="true".

This worked very well in the previous version, but is not working that great now.

Any ideas?

::m
Jan 8, 2009 at 11:56 AM
Might be a bug in the urlcache, try disabling it:

<n2><host><web><urls cache="false"
Jan 8, 2009 at 12:54 PM
That did the trick!

The bug is confirmed then.

Thanks alot for your help!
Jan 8, 2009 at 6:24 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jan 29, 2009 at 10:41 PM
I have same problem.
I added:

   <host rootID="1" startPageID="2" multipleSites="true">
      <web extension=".aspx" ignoreExistingFiles="true">
        <urls cache="false" />
      </web>
      <outputCache enabled="false" duration="10" />
    </host>

And I have error:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'cache'. Note that attribute names are case-sensitive.

Source Error:

Line 30:     <host rootID="1" startPageID="2" multipleSites="true">
Line 31:       <web extension=".aspx" ignoreExistingFiles="true">
Line 32:         <urls cache="false" />
Line 33:       </web> 
Line 34:       <outputCache enabled="false" duration="10" />

Jan 29, 2009 at 10:54 PM
Andreyd,

I think Libardo was a bit fast when he wrote the reply to me (or had his mind on some old code)

The correct syntax is:

<

 

host rootID="1" startPageID="2" multipleSites="true">
    <
web extension=".aspx" ignoreExistingFiles="true">
        <
urls enableCaching="false" />
    </
web>
    <
outputCache enabled="true" duration="60" />
</
host>

Cheers!

::m

 

Jan 29, 2009 at 11:00 PM
Thanks.
Feb 11, 2009 at 6:33 PM
This solved my problem exactly!

Thanks,
Dustin
Mar 16, 2009 at 3:01 PM
If I understand this correctly the solution is to disable url caching. In the latest build however the issue is solved and you don't need to disable it?
Either way. Why is the url caching necessary or what does it do?

Also. In a previous project I used this tool:
http://www.aspalliance.com/CacheManager/Default.aspx

Is there a way to manage what's in the cache in a similar fashion with N2?

Mar 16, 2009 at 9:19 PM
It's a performance optimization that can avoid the need to load up all siblings leading up to a certain page.

I can't see how the aspnetalliance could help. Can you explain?
Mar 17, 2009 at 10:24 AM
The CacheManager from aspallicance was used in previous projects to clear specific items from the cache without clearing everything and thereby affecting performance.
Mar 17, 2009 at 6:23 PM
Okay, I see. I don't think this will be a problem since the url cache is expired by a cache dependency. Please let me know if there are any problems.