Who has a "NHibernate.JetDriver.dll"(Version 1.2.0.4000)

Topics: Developer Forum, Project Management Forum, User Forum
Dec 10, 2007 at 2:25 AM
I have downloaded the N2 Releases Version 1.3.1, but the database It suports is "Sqlserver". Now I want use "Access" database. So I download the newest version of NHibernate.JetDriver.dll(1.2.1.4000), but I met this wrong——"异常详细信息: System.IO.FileLoadException: 未能加载文件或程序集“NHibernate, Version=1.2.1.4000, Culture=neutral, PublicKeyToken=aa95f207798dfdb4”或它的某一个依赖项。找到的程序集清单定义与程序集引用不匹配。 (异常来自 HRESULT:0x80131040)
" I guess the reason is the version of "NHibernate.JetDriver.dll" is wrong. Everyone Who has met this problem or has a "NHibernate.JetDriver.dll"(Version 1.2.0.4000), please give me a help.
Thanks a lot!
Coordinator
Dec 10, 2007 at 10:33 AM
Looks like a new version of nhibernate has been released since N2 v1.3.1. You could try re-referencing the new version of nhibernate and recompiling N2.dll or doing an assembly redirect http://msdn2.microsoft.com/en-us/library/7wd6ex19(VS.71).aspx. You should also consider using sql 2005 express instead of jet if possible.

Anyway, it would be interesting to hear whether jet works.

/Cristian